Skip to Content

UO: Safari problems with Blackboard

All Safari users: please switch to Firefox.
The current versions of Safari are not fully compatible with Blackboard. Apple made some changes in the way that Safari works that cause problems when using Blackboard. We will continue to work with Blackboard Inc. on finding a solution to these problems. At the latest they should be fixed with the version that we are planning on installing in late December. Until then we recommend that you not use Safari and instead use Firefox when using Blackboard.
Source: UO Libraries