CIS Browser Requirements

To implement  CIS, you need an Internet delivery system with the capability to display all CIS content, including all CIS exploration modulesand the Portfolio. Minimum browser requirements are:

  • Cookies Enabled
  • Pop-ups allowed
  • JavaScript Enabled
  • Windows – Firefox 10.0+, Internet Explorer 8.0+, or Chrome 14.0+
  • Mac – Firefox 10.+ , Safari 5.0+, or Chrome 14.0+
  • Audio device and speakers

Comments are closed.